file not recognized: File truncated

While attempting to upgrade one of my Gentoo Linux machines to the latest version of PulseAudio ( media-sound/pulseaudio-2.0 ) today I encountered the following error:

libtool: install: /usr/bin/install -c .libs/libprotocol-cli.soT /var/tmp/portage/media-sound/pulseaudio-2.0/image//usr/lib64/pulse-2.0/modules/libprotocol-cli.so
libtool: install: /usr/bin/install -c .libs/libprotocol-cli.lai /var/tmp/portage/media-sound/pulseaudio-2.0/image//usr/lib64/pulse-2.0/modules/libprotocol-cli.la
libtool: install: warning: relinking `libprotocol-simple.la'
libtool: install: (cd /var/tmp/portage/media-sound/pulseaudio-2.0/work/pulseaudio-2.0/src; /bin/sh /var/tmp/portage/media-sound/pulseaudio-2.0/work/pulseaudio-2.0/libtool  --silent --tag CC --mode=relink x86_64-pc-linux-gnu-gcc -std=gnu99 -I../src -I../src/modules -I../src/modules -pthread -DPA_ALSA_PATHS_DIR=\"/usr/share/pulseaudio/alsa-mixer/paths\" -DPA_ALSA_PROFILE_SETS_DIR=\"/usr/share/pulseaudio/alsa-mixer/profile-sets\" -march=core2 -msse4.1 -O2 -pipe -Wall -W -Wextra -Wno-long-long -Wvla -Wno-overlength-strings -Wunsafe-loop-optimizations -Wundef -Wformat=2 -Wlogical-op -Wsign-compare -Wformat-security -Wmissing-include-dirs -Wformat-nonliteral -Wpointer-arith -Winit-self -Wdeclaration-after-statement -Wfloat-equal -Wmissing-prototypes -Wredundant-decls -Wmissing-declarations -Wmissing-noreturn -Wshadow -Wendif-labels -Wcast-align -Wstrict-aliasing -Wwrite-strings -Wno-unused-parameter -ffast-math -Wp,-D_FORTIFY_SOURCE=2 -fno-common -fdiagnostics-show-option -Wl,-z,nodelete -avoid-version -Wl,-O1 -Wl,--as-needed -Wl,--no-as-needed -o libprotocol-simple.la -rpath /usr/lib64/pulse-2.0/modules protocol-simple.lo libpulsecore-2.0.la libpulsecommon-2.0.la libpulse.la -lgdbm -lcap -lrt -ldl -lm -inst-prefix-dir /var/tmp/portage/media-sound/pulseaudio-2.0/image/)
/var/tmp/portage/media-sound/pulseaudio-2.0/work/pulseaudio-2.0/src/.libs/libpulsecore-2.0.so: file not recognized: File truncated
collect2: ld returned 1 exit status
libtool: install: error: relink `libprotocol-simple.la' with the above command before installing it
make[4]: *** [install-modlibexecLTLIBRARIES] Error 1

As far as I can tell, the problem seems to be that ( on some machines, my other Gentoo machine installed the package without issue ) multiple threads are trying to access the same files at the same time and erroring. To work around this , I simply installed the package using one thread:

MAKEOPTS="-j1" emerge  media-sound/pulseaudio

2 thoughts on “file not recognized: File truncated”

  1. Hi,

    I had the same error. Using portage 2.3.3-r4 I completed the MAKEOPTS with -l option.
    In my case with a dualcore it’s look like that :
    MAKEOPTS=”-j3 -l3″

    After that Pulseaudio-2.0 complete installation.

Leave a Reply

Your email address will not be published. Required fields are marked *